Tag Archives: Lab

The Interview

I´ve been working in Networking/Security Field for a while and most of my interviews didn´t have a deep technical session like my last one. A friend of mine (André) suggested me to apply for a Technical Consultant Role like him did last year, and after talk with him about his projets i decided to go ahead and i made my application online.
This took a while to get the first call from HR and schedule my interview, after that it was more relief and excited.

The interview took me half a day, it was composed by a technical session and a session with HR.

The funny part was the technical :) , you know why!

What i found on technical session?

I had a lots of questions and a surprise LAB!

This is what i remember so far….
What OSPF LSA do you know?And what is purpose of which one?
Multicast types, why use it?
Spanning-Tree versions,Timers,Port-roles, etc
Routing Protocols, timers

I also had a few general questions about LDAP, DNS, etc

LAB (30 minutes)

It was composed by 6 routers and 2/3 switches, and had technologies like MPLS,L3VPN, IS-IS,BGP,STP,VRF and much more

The first 20 minutes was to analyse the network and take notes to explain in 10 minutes what i saw and make some comments to improve the customer network.

The most challenging part for me was Presenting for a Technical and Business person, about a technology i had to choose among of OTV, FabricPath, VSS, etc and i picked up FabricPath and i did well :)

HR

This part took 1 hour and a half maybe, a nice fellow explained me everything about the company and we went deep in my CV about all my previous experiences/projects why i left what made me move forward and so on.The benefits were really nice specially training and bonus :)

Offer or not?

Finally i received an offer, but i declined because of personal reasons….

DAMMIT! But it worthed by the experience!

Deja vu CCIE R/S Lab 2 attempt

Segunda tentativa e prometia, dormi relativamente bem, um pequeno-almoço soft, 10 minutos de caminhada ate ao edifício da Cisco. A v4 e realizada em 2 partes TS+Config , ate aqui nada de novo, e antes de iniciar o TS (troubleshooting) abri notepad e calculadora e sumarizei alguns comandos para conseguir despistar mais rapidamente os tickets.

Quando o proctor me indicou o meu rack, fiquei estupefacto. Outra vez o 9? Mas ia com uma coisa em mente, se tivesse outra vez o mesmo teclado, duro que nem um pedra que para digitar um paragrafo era preciso primeiro almoçar por 2, ia sugerir ao proctor para trocar. Curiosamente não foi preciso, o teclado era macio como o novo que comprei a 3 meses atrás, definitivamente isto e um jogo psicológico de alto nível.

Portanto eu diria que isto e um jogo de 70% technical skills, e o restante jogo psicológico

Troubleshooting

Iniciado o exame, começou uma corrida desenfreada contra o tempo tentando resolver o mais rapidamente possível os tickets, saltei 2 tickets inicialmente, a cada momento que resolvia um ticket a minha confiança aumentava. A 15 minutos do fim com 9 tickets resolvidos, fiquei com um dilema…Rever os tickets ou avançar para o ultimo (multicast)? Decidi fazer um quick check a todos os tickets e todos estavam conforme solicitado. A 1 minuto do fim ainda iniciei o ultimo ticket mas a sessão terminou.

Estava bastante confiante mas ao mesmo tempo sabia que se tivesse resolvido o ultimo ticket a probabilidade de passar no TS era maior.

Os comandos usados foram:

term len 0
sh runn | i cef|mpls|interface|area|auth|message|access|prefix|polic|route|ipv6

sh runn | sec router

!Para questões relacionadas com multicast

sh runn | i interface|pim|igmp|msdp|multicast|route|access

sh ip pim nei

Configuration

Antes de começar a Config, estiquei as pernas, bebi um café e respirei um pouco, pois durante 2 horas a minha capacidade de análise/resolução estivera a velocidades jamais alcançadas numa montanha russa.

Nesta parte do exame, iniciei bastante bem apenas deixei a parte do multicast como ultima questão. A 30 minutos do fim comecei a rever todo o exame com a questão do multicast por fazer, entretanto o proctor informou para gravar as configurações porque estava na hora de ir para casa.

Resumindo estava em boas condições de passar, mas só me restava esperar pelo resultado oficial.

Os comandos usados foram:

!Para a seccao de Config
conf t
ip cef
ip routing
config-register 0x2102

Resultado:

Sexta-feira de manha recebi o resultado, tinha conseguido falhar novamente apesar de ter realizado um bom exame, muito superior que na primeira vez.

Desta vez obtive:

Resultado: FAIL
TS 73%
Config 70%

Desta vez faltou o factor sorte, que também e preciso!

Com o fim da v4 a vista, terei que realizar a nova versão v5 anunciada o ano passado, o formato do exame muda ligeiramente com uma nova secção de diagnostico, e com a adição/remoção de algumas tecnologias do LAB.

Agora e tempo de relaxar, e espero realizar novamente o exame no espaço de um ano.

Depois de tantas horas de estudo em CLI Cisco, esta na hora de aprender algo sobre Juniper.

Aproveito para deixar publicado as minhas Notas CCIE RS v4 (45Mb), resumo pelo qual estudei para o exame. Este documento foi criado com base em leituras de livros, RFCs.

dejavu

CLI em modo menu

Usar Menus poderá ser uma forma rápida de permitir acesso a algumas das funções dos equipamentos. Existem outras formas como CBAC, ou atribuindo diferentes privilégios aos users.
username SOC privilege 15 password 0 CISCO
!Apos autenticação o user e redirecionado para o Menu através do autocommand
username SOC autocommand menu SOC
!
menu SOC title #
Menu for Level 1 SOC users
#
menu SOC text 1. Show Running Config
menu SOC command 1. show running-config
menu SOC text 2. Show Interface Brief
menu SOC command 2. show ip interface brief
menu SOC text 3. Show clock
menu SOC command 3. show Clock
menu SOC text 4. Exit
menu SOC command 4. exit

line vty 0 903
login local

Testando o respectivo Menu criado

R3#telnet 192.168.1.1
Trying 192.168.1.1 … Open

User Access Verification

Username: SOC
Password:
Menu for Level 1 SOC users

1.         Show Running Config

2.         Show Interface Brief

3.         Show clock

4.         Exit

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.1.1      YES NVRAM  up                    up

Menu for Level 1 SOC users

1.         Show Running Config

2.         Show Interface Brief

3.         Show clock

4.         Exit

*03:53:17.163 UTC Fri Mar 1 2002
Menu for Level 1 NOC users

1.         Show Running Config

2.         Show Interface Brief

3.         Show clock

4.         Exit

[Connection to 192.168.1.1 closed by foreign host]
R3#

Mais uma rodada de 6 Labs

A precisão começa a aumentar, o que e óptimo mas por vezes ainda tenho alguns soluços :) pois tenho dúvidas em escolher a melhor solução tendo em conta de não violar os requisitos da Task. Bem por vezes a solução do INE não coincide com a minha mas o resultado final é o mesmo. Por vezes aparecem questões muito especificas sobre determinada feature, estas ficam para analisar no fim.

CCIE entre o jogo das cadeiras

Tentei marcar o Lab para Dezembro em Londres (Mobile LAB), seria uma oportunidade excelente dado que estou a trabalhar aqui, mas quando tentei marcar alguém se antecipou e ficou-me com o lugar… :(
Bem, agora só me resta marcar para Janeiro e neste caso será em Bruxelas, mais uma semana e esta marcado depois começam os nervos, ansiedade, sensações obscuras e sabe-se lá o que mais virá….

schedule-labccie-1

 

% not enough space on flash to store vlan database. trying squeeze…

Durante um dos labs no gns3 deparei-me com este erro, e com um write mem resolvi o problema  :-D

Client(config)#vtp mode c
Setting device to VTP CLIENT mode.
% not enough space on flash to store vlan database. trying squeeze...
squeeze of flash complete
% not enough space on flash to store vlan database even after squeeze
Client(config)#do wr mem
Building configuration...
[OK]
Client(config)#vtp mode c
Device mode already VTP CLIENT.
Client(config)#

Quais os pilares para o sucesso no CCIE?

Será o CCIE um dos exames mais exigentes da indústria de IT? Quais os pilares para o seu sucesso?

Aqui fica uma grande apresentação, com dinâmica, entusiasmo e veracidade no Cisco Live pelo Anthony Sequeira, instrutor na StormWind e autor de alguns livros Cisco Press.

O sucesso no exame passa por: Estratégia, Determinação

Referência:
Cisco Live 365

Qual a estratégia para o exame CCNP-TSHOOT?

Este exame é composto por 3 secções, os quais já descrevi aqui no blog. A minha preocupação eram os 13 tickets do Lab devido ao fator tempo, e não tanto as questões da 1ª e 2ª secções.

Notas para o Exame

  • Todos os tickets resumem-se a problemas de falta de conetividade entre o Cliente1 e o Servidor Web.
  • No Cliente1 apenas é possível executar comandos de ping/ipconfig
  • Todos os tickets são totalmente independentes, ou seja, o Cliente1 pode ter IP no Ticket 1 e não no Ticket 2 (misconfig DHCP)
  • Durante o exame não é necessário efetuar qualquer configuração, apenas indicar qual o equipamento causador do problema e a respetiva solução.

Estratégia antes do Exame

  • Configurar de raíz a topologia no GNS3, permite ficar familiarizado com a mesma

Estratégia durante o Exame

  1. Verificar se o Cliente1 tem IP
  2. Verificar a existência de conetividade entre o Cliente1 e o Gateway
  3. Verificar a existência de conetividade entre o Cliente1 e os diferentes Routers (R1;R2;R3;R4)
  4. Verificar a existência do routing do Servidor Web e a subnet do Cliente1 nos diversos Routers

Os tickets podem apresentar problemas relacionados com: HSRP, VLAN Allowed, Peering BGP, DHCP,  Routing Redistribute, Routing Authentication, VACL, NAT entre outras.

Encontram-se abaixo disponíveis as topologias para o GNS3 e Packet-Tracer.

Topologia TSHOOT GNS3
Topologia TSHOOT Packet Tracer

Os Mobile CCIE Labs da Cisco

A Cisco introduziu o programa Mobile CCIE Lab, este permite que os candidatos tenham acesso exame de Laboratório reduzindo os custos (Viagens,Alojamento,etc…) e claramente tempo (um dos bens mais preciosos!).
Os Labs estão disponíveis apenas para as certificações CCIE: Routing & Switching, Security e Voice , algumas destas não são permanentes em alguns locais.

Visão Global dos locais (permanentes ou Mobile) onde é possível realizar os exames:

Os Labs permanentes relativamente perto são na Bélgica e Itália, em Inglaterra já está confirmado o Mobile de 21 a 25 Janeiro 2013 para os Labs de Routing & Switching e Security.

Infelizmente ainda não está nenhum previsto para Portugal até 2013, não invalida que a Cisco nos brinde brevemente!

Referências:
Mobile CCIE Labs Overview

Introdução ao VRF-Lite

O Virtual Routing and Forwarding (VRF) é uma tecnologia que permite ter diversas instâncias de Routing possibilitando ainda o overlap de endereçamento em simultâneo no mesmo router.
Este tipo de tecnologia é comum em MPLS nos Service Providers.
O VRF-Lite é uma versão mais básica do VRF, tendo por base o mesmo conceito. Para utilizar esta versão, não é necessário como pré-requisito a existência de uma rede MPLS.

Um dos exemplos comuns onde esta tecnologia é utilizada, é na segregação lógica de diversos clientes no mesmo equipamento.

O VRF funciona apenas em Layer 3, portanto deve ser configurado em interfaces físicas ou lógicas (SVI).

Com base na figura acima, toda a lógica da configuração foca-se no R1, nos restantes routers apenas será necessário configurar a respetiva interface e definir a default route.

Configuração:

Configurar o VRF A no R1, a definição do RD é opcional

ip vrf A
rd 100:100

Configurar o VRF B no R1, a definição do RD é opcional

ip vrf B
rd 101:101

Configurar o endereçamento IP das interfaces e definir a VRF

interface FastEthernet0/0
ip vrf forwarding A
ip address 10.1.2.2 255.255.255.252
!
interface FastEthernet0/1
ip vrf forwarding A
ip address 10.1.1.2 255.255.255.252
!
interface FastEthernet1/0
ip vrf forwarding B
ip address 10.1.2.2 255.255.255.252
!
interface FastEthernet2/0
ip vrf forwarding B
ip address 10.1.1.2 255.255.255.252

Verificar as diferentes VRFs e interfaces associadas

R1#sh ip vrf
Name Default RD Interfaces
A 100:100 Fa0/0 Fa0/1
B 101:101 Fa1/0 Fa2/0

Verificar a tabela de routing relativa a cada VRF

R1#sh ip route vrf *
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

Routing Table: B
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/30 is subnetted, 2 subnets
C 10.1.2.0 is directly connected, FastEthernet1/0
C 10.1.1.0 is directly connected, FastEthernet2/0

Routing Table: A
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/30 is subnetted, 2 subnets
C 10.1.2.0 is directly connected, FastEthernet0/0
C 10.1.1.0 is directly connected, FastEthernet0/1

Testando a conetividade com o R3 apartir do R2

R2#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/76/176 ms

Testando a conetividade com o R4 apartir do R5

R5#ping 10.1.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/49/72 ms

!Testando a conetividade com origem no VRF

R1#ping vrf ?
WORD VPN Routing/Forwarding instance name

R1#ping vrf A 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/39/96 ms
R1#ping vrf B 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/64 ms
R1#ping vrf B 10.1.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/36/60 ms
R1#ping vrf A 10.1.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/33/80 ms
R1#

LAB GNS3:

Encontra-se disponível para download o LAB sobre VRF-Lite.

Referências:
Cisco – Configuring VRF-lite
MPLS Multi-VRF (VRF-lite) – Multiprotocol Label Switching for VPNs (MPLS for VPNs)