Tag Archives: SFP Failure

SFP validation failed on Nexus

If you come across to an issue like this you are about to fix before that you think. After plug in SFP (1 gig copper) on a SFP+ port i got an error saying “SFP validation failed”.

N3K# sh int e1/45
Ethernet1/45 is down (SFP validation failed)
Dedicated Interface
Hardware: 100/1000/10000/40000 Ethernet, address: 00d7.8fa9.34b4 (bia 00d7.8fa
9.34b4)
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
Full-duplex, 10 Gb/s, media type is 1G
Beacon is turned off
Input flow-control is off, output flow-control is off
Rate mode is dedicated
Switchport monitor is off
EtherType is 0x8100
Last link flapped never
Last clearing of “show interface” counters never
0 interface resets
Load-Interval #1: 30 seconds
30 seconds input rate 0 bits/sec, 0 packets/sec
30 seconds output rate 0 bits/sec, 0 packets/sec
Load-Interval #2: 5 minute (300 seconds)
input rate 0 bps, 0 pps; output rate 0 bps, 0 pps

So we have to force the interface speed like old days.

N3K(config)# interface Ethernet1/45
N3K(config-if)# speed 1000
N3K(config-if)# no shut

Plugin the cable and done!

N3K(config-if)# show int e1/45
Ethernet1/45 is down (Link not connected)
Dedicated Interface
Hardware: 100/1000/10000/40000 Ethernet, address: 00d7.8fa9.34b4 (bia 00d7.8fa
9.34b4)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
Full-duplex, 1000 Mb/s, media type is 1G