Notas PPPoE

O PPPoE é largamente para o acesso internet digital subscriber line (DSL), devido á rede telefónica usar ATM como protocolo de transporte.
Num ambiente DSL, o endereço IP da interface PPP deriva do server DHCP usando o IP Configuration Protocol (IPCP). Portanto, a negociação do endereço IP deve ser ativa na interface dialer do router. Para isto deve ser usado o comando ip address negotiated na config do dialer interface.

Devido ao header PPP ter 8 bytes, o MTU para o PPPoE é definido como 1492. Um mismatch do MTU previne que a conexão PPPoE fique UP.

PPPoE_server#
bba-group pppoe PPPOE
virtual-template 1
!
interface FastEthernet0/1
ip address 192.168.10.1 255.255.255.0
duplex auto
speed auto
pppoe enable group PPPOE

interface Virtual-Template1
ip address 10.10.10.3 255.255.255.0
ip mtu 1492
peer default ip address pool PPPOE
!
ip local pool PPPOE 10.10.10.1 10.10.10.2

PPPoE_client#

interface FastEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 1
dialer-group 1
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit

PPPoE_client#sh pppoe session
1 client session

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
SID  LocMAC                                      VA-st
N/A     28  c200.154c.0001  Fa0/0                  Di1  Vi2        UP
c204.154c.0000                              UP

PPPoE_client#sh pppoe session all
Total PPPoE sessions 1

session id: 28
local MAC address: c204.154c.0000, remote MAC address: c200.154c.0001
virtual access interface: Vi2, outgoing interface: Fa0/0
235 packets sent, 234 received
3704 bytes sent, 3710 received

PPPoE_client#sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

10.0.0.0/32 is subnetted, 2 subnets
C       10.10.10.3 is directly connected, Dialer1
C       10.10.10.1 is directly connected, Dialer1
S*   0.0.0.0/0 is directly connected, Dialer1

PPPoE_client#sh ip int br | ex una
Interface                  IP-Address      OK? Method Status                Protocol
Dialer1                    10.10.10.1      YES IPCP   up                    up

PPPoE_client#ping 10.10.10.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/28/40 ms

PPPoE_server# sh pppoe session
1 session  in LOCALLY_TERMINATED (PTA) State
1 session  total

Uniq ID  PPPoE  RemMAC          Port                    VT  VA         State
SID  LocMAC                                      VA-st
28     28  c204.154c.0000  Fa0/1                    1  Vi1.1      PTA
c200.154c.0001                              UP

PPPoE_server#  sh pppoe session all
Total PPPoE sessions 1

session id: 28
local MAC address: c200.154c.0001, remote MAC address: c204.154c.0000
virtual access interface: Vi1.1, outgoing interface: Fa0/1
244 packets sent, 245 received
3850 bytes sent, 3844 received

PPPoE_server#  sh ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/24 is directly connected, Virtual-Access1.1
C       10.10.10.1/32 is directly connected, Virtual-Access1.1

Leave a Reply

Your email address will not be published. Required fields are marked *